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Intermediate ArcGIS Pro 
 

Research Question: I’m looking for a place to live in Ottawa and will be using my bicycle 

to get around. I want to know which Ottawa neighbourhoods have the most bike lanes 

and paths, and are any bike paths within 50 metres of places I need to get to? 
 

1. Data acquisition 
a. Data & documentation link: http://tinyurl.com/TrajectoriesGIS  

b. Data is all from Open Data Ottawa and downloaded in March 2024: 

a. …except for CommunityGardens.csv, which is from 2020 (although not many changes 

with the current dataset), and we’re using it due to the fact that it has XY coordinates 

and isn’t a shapefile or other geospatial file type. 

b. Pedestrian Network 

c. Cycling Network 

d. Ottawa Neighbourhood Study (ONS) - Neighbourhood Boundaries Gen 3 

2. Getting organized and familiar with the datasets 
a. Launch ArcGIS Pro 

b. Under New templates, click Map 

c. When prompted, provide a name for your project and browse to the location where you’d like 

to save it. Click OK. 

 

This will create specific folders for your project. 

In Windows Explorer:  
 

d. We’re going to change to Windows Explorer. Navigate to your new project folder in Windows 
Explorer. It should look something like this: 

http://tinyurl.com/TrajectoriesGIS
https://open.ottawa.ca/datasets/community-gardens/explore
https://open.ottawa.ca/datasets/community-gardens/explore
https://open.ottawa.ca/datasets/pedestrian-network/explore?location=45.261342%2C-75.762080%2C1.51
https://open.ottawa.ca/datasets/cycling-network/explore
https://open.ottawa.ca/datasets/ottawa-neighbourhood-study-ons-neighbourhood-boundaries-gen-3/explore?location=45.244008%2C-75.801092%2C1.36
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a. The .gdb folder is the project geodatabase that ArcGIS Pro automatically creates 
b. The .aprx file is the map file 
c. The .tbx file is the project toolbox, where you could save tools you use or build 

e. Add a new folder called shapefiles 

 
f. Unzip the shapefiles you downloaded and save them in the new shapefiles folder 

 

 

g. Go back to ArcGIS Pro, in the right-hand pane, click on the Catalog tab at the bottom, then 

double-click on Folders. You should see your project folder, and if you open it you should see an 

ImportLog folder, plus geodatabase and toolbox. 

a. If you don’t see your new shapefiles folder, right-click on your project folder and 

Refresh 
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h. Click and drag the shapefiles into the Map pane 

i. Open the attribute tables for the shapefiles and have a look at what kind of information is 

provided, and think about what may be helpful for us 

 

Select by Attribute 
a. Pedestrian_Network has some relevant data but some that isn’t useful for us (since we 

shouldn’t ride our bicycle on the sidewalk), so let’s only extract the multi-use pathways. 

a. Select the Map ribbon > Select By Attributes 

b. Select features from Pedestrian_Network where WALK_TYPE is equal to MUP 

c. Click Apply 
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There should be 2,918 features selected when viewing the attribute table. 

d. Click OK to close the Select By Attributes window 

 

b. Right-click on Pedestrian_Network in Contents and select Data > Export Features (could also 

click on the name of the shapefile in the Contents pane, then the Export Features button in the 

Feature Layer > Data ribbon) 

a. Input Features: PedestrianNetwork 

i. There’s a note that “The input has a selection. Records to be processed: 2,918” 

which is exactly what we want. 

b. Output Feature Class: MultiUsePathways 

i. When you click on the text box to change the output name, note that the file 

will save to the project geodatabase. 

ii.  



Intermediate ArcGIS Pro  5 
 

 
c. Click OK 

d. In the table of contents, right-click on the new MultiUsePathways feature layer and select 

Properties > Source 

a. In the Data Source section, note that the Data Type is File Geodatabase Feature Class 

and it indicates the file path for the geodatabase 

i. For shapefiles, the Data Type is Shapefile Feature Class 

e. Right-click on Pedestrian_Network shapefile and select Remove  

Copy shapefiles into the geodatabase 
a. Since we have our MultiUsePathways feature layer in the geodatabase, let’s copy the other two 

shapefiles into the geodatabase as well so they’re all in one location 

a. In the Map ribbon in the Selection section, click the Clear button  to ensure no 

features are selected 

i. If they are, only those features will be exported 

ii. if the button is greyed-out, there are no features selected and you’re good to go 

b. In the table of contents, right-click a shapefile and select Data > Export Features 

c. Ensure that the Output Location is the project geodatabase 

d. Give the Output Feature Class a name (e.g.: CyclingNetwork or OttawaNeighbourhoods) 

e. Click OK 

f. Repeat for the other shapefile 

b. If you click on the Catalog pane, your file structure should look something like this: 



Intermediate ArcGIS Pro  6 
 

 
c. In the table of contents, right-click and remove the cycling network and neighbourhood 

shapefiles, keeping only the geodatabase feature classes. Your map should look something like 

this: 
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3. Using a CSV file with latitude & longitude coordinates 
Sometimes geospatial files (shapefiles, KMZ, geodatabases, etc.) aren’t available, but it’s possible to use 

any dataset that has latitude & longitude coordinates. 

How can I tell if data has latitude and longitude? 
Have a look at the CSV or Excel file! The coordinates may be called X and Y, latitude and longitude, or 

some combination of those but the numbers should look like these (-75 and 45): 

 

Displaying X,Y Data 
a. In ArcGIS Pro, go to the Catalog and your project folder. The CSV file may be in the shapefiles 

folder. 

b. Click and drag the CSV into the map window. In the Contents, you should now have a 

Standalone Table that is your CSV file: 

i.  
ii. Right-click on your CSV and select Open to view the attribute table. Review the 

attributes and particularly make note of the latitude and longitude (or X and Y) fields. 

c. Once you know which fields are your latitude and longitude, right-click on the CSV and select 

Display XY Data 

d. The XY Table To Point geoprocessing tool should appear on the right and may already have fields 

filled in. 

i. X Field: either X or longitude 

ii. Y Field: either Y or latitude 

iii. Give it a helpful name (e.g. CommunityGardens) 

iv. Coordinate system: GCS_WGS_1984 (this is not a projection but a coordinate system, 

and its unit is degrees) 
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v.  
e. Click OK 

f. After a moment or two, you should see points appear on your map in the city of Ottawa 

 
i. Common error: if you zoomed to the new layer and the points show up in Antarctica, 

the X/longitude and Y/latitude got mixed up so just run it again after correcting that 

error. 

g. You can remove the CSV standalone table from your map. 

h. Your map should now have the following datasets: 

i. Your new points feature class (e.g.: community gardens) 

ii. Multi-use pathways line feature class 

iii. Cycling network line feature class 

iv. Ottawa neighbourhoods polygon feature class 
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4. Some final data preparation 
Lots of work to prepare the data! 

For the sake of this analysis, we’re going to consider both the multi-use pathways and cycling network to 

be bike-friendly and we don’t want to distort our analysis if the two layers overlap or fall within a few 

metres of one another. In other words, if the cycling network and multi-use pathways overlap or run 

parallel, we want to ensure we don’t count them twice. A good example of this is in the Experimental 

Farm west of Carleton, where the same paths are included in both datasets. 

There are many ways of de-duplicating data and we will use two methods in this workshop. 

Select by Location 
a. We’re going to start by selecting features that are identical. Go to the Map ribbon and Select By 

Location 

b. We’re going to select features that are identical in both the MUP and Cycling Network datasets. 

Fill in the Select Layer By Location form as follows (MultiUsePathways features are the ones that 

will be selected based on their relationship to CyclingNetwork): 

i.  
c. Click Apply to ensure that some features are selected. If so, click OK. 

d. Open the MultiUsePathways attribute table and there should be 246 features selected. 
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i.  
e. Because we want to ensure we don’t eliminate any data, we’re going to export only the 

MultiUsePathways that *don’t* match perfectly with the cycling network. To do so, we’re going 

to start by clicking the Switch Selection button in the attribute table. 

i.  
f. There should now be 2672 features selected. Right-click on the MultiUsePathways feature class 

and Data > Export Features 

g. Name the Output Feature Class something helpful, like MUP_noSameCyclePath (that’s a bit 

awkward but at least I know what it means). Click OK. 

i. Reminder in addition to the blue text, that ArcGIS Pro automatically saves ONLY the 

selected features if there are any selected 

ii.  
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Creating a Buffer 
Since there are still cycling paths that run parallel to (or are mostly the same as) the multi-use pathways, 

we’re going to create a buffer around the cycling paths and clip (remove) the MUPs that fall within those 

buffers. An example of this is on the side of Dows Lake along Queen Elizabeth Driveway. 

a. In the table of contents, click on the CyclingNetwork feature class, then go to the Analysis 

ribbon and in the tools portion, find the Pairwise Buffer tool 

 
b. Fill it in as follows and Run. 

i. We’re selecting to “Dissolve all output features into a single feature” as it eliminates 

overlap between the resulting buffer polygons, so there’s only one layer of buffer 

polygons. 
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Erase Features within the Buffer 
a. Now that we have the 5-metre buffers around the cycle network, we’re going to erase all the 

multi-use pathways that fall within that buffer area. In the Analysis ribbon, click on More tools… 

i.  
b. Type ‘erase’ into the search box 

c. Click on the Erase (Analysis Tools) option. When the Geoprocessing pane loads with the Erase 

options, hover over the question mark to see a visualization of what this tool will do. 

d. Fill in the properties as follows and click Run: 

 
e. While the results of this workflow aren’t perfect, it reduces the overlap sufficiently to proceed 

with a more accurate analysis of the cycling infrastructure than where we started. It also 

reduces the overlap sufficiently to manually remove multi-use pathways that you may consider 

too close, duplicating, or overlapping the cycling network. 
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Merge GIS Data 
Now – finally – we’re going to merge both the MUPs and cycling network into one dataset to 

perform the analysis. Go to the Analysis ribbon and select Merge. 

 

i.  
f. SHAZAM! Now remove all the extra feature classes from the table of contents that we don’t 

need anymore, keeping only your community gardens points feature class, the 

CyclingNetwork_MUPs feature class, and the neighbourhoods. 
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5. Analysis time! 
If you’re thinking we spent a whole lot of time getting and preparing the data to do the analysis, you’re 

right! This is a realistic reflection of geospatial work and the next step is figuring out which tool to use 

for your analysis. Most analysis can be done with using a variety of tools and methods. The trick is 

correctly identifying the tool(s) to use by exploring the documentation. 

Our question is: I’m looking for a place to live in Ottawa and will be using my bicycle to 

get around. I want to know which Ottawa neighbourhoods have the most bike lanes and 

paths, and are any bike paths within 50 metres of places I need to get to? 
 

In the Geoprocessing window, click on Toolboxes > Analysis Tools and explore some tools by clicking on 

them and reading the documentation. You can also get an overview of the Analysis toolbox from ArcGIS 

Pro Help: https://pro.arcgis.com/en/pro-app/3.1/tool-reference/analysis/an-overview-of-the-analysis-

toolbox.htm. Which tool(s) do you think might help? 

Which Ottawa neighbourhoods have the most bike lanes and paths?  
After reading the documentation, the Summarize Within tool sounds promising. This tool will allow us 

to extract the summarized length of lines within each neighbourhood, or find the total length of the 

cycling network & MUPs in each neighbourhood, which is what we want. 

a. Fill in the Summarize Within properties and click run: 

i.  

https://pro.arcgis.com/en/pro-app/3.1/tool-reference/analysis/an-overview-of-the-analysis-toolbox.htm
https://pro.arcgis.com/en/pro-app/3.1/tool-reference/analysis/an-overview-of-the-analysis-toolbox.htm
https://pro.arcgis.com/en/pro-app/3.1/tool-reference/analysis/summarize-within.htm
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b. Open the attribute table for the OttawaNeighbourhoods_totalCyclingNetwork feature class. 

Note the differences between the two length sum fields, and that the Summarized Length in 

METERS field is always smaller. 

i.  
c. Let’s visualize it! Right-click on the layer in Contents and select Symbology. 

d. For Primary Symbology, select Graduated Colours. 

i.  
e. Make sure you select “Summarized Length in METERS” as the Field 

f. Choose a colour scale and a method for dividing the data into classes (5 classes and Natural 

Breaks is generally a decent place to start). Your map should look something like this: 

 
g. Consider using this tool with just the cycling Network feature class.  
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Are any bike paths within 50 metres of places I need to get to? 
a. Now that we know the length of the cycling network within each neighbourhood, let’s find out 

how many community gardens are within 50 metres of the cycling network. 

b. In the Analysis ribbon, find the Near tool 

i.  
c. Fill out the properties as below and click Run: 

i.  
d. Once the process is complete, open the attribute table for Community Gardens. At the far right 

of the table, there should be two fields called NEAR_FID and NEAR_DIST.  

i. The NEAR_FID is the closest bike path, and the distance is how far away the nearest bike 

path is. 

ii. Gardens that had no bike paths within 50 metres have -1 in both fields 
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e. Let’s symbolize the community gardens based on if the locations are within 50m of the cycling 

network. 

i. Primary Symbology: Unique Values 

ii. Field 1: NEAR_DIST or NEAR_FID (doesn’t matter at this point) 

iii. Click on the first value that is not -1, hold down the Shift key, and scroll down to click on 

the last item in that list 

iv. Right-click one of the highlighted rows and select Group Values 

a.  
v. Click on the symbol for the -1 row, then select a symbol 

a.  You can search the Gallery, for example ‘x’ or ‘plant’ 

b.  Click the Properties tab at the top to change the size, colour, style, etc. of the 

symbol you choose 

c.  Click Apply to see your changes 

vi. Once you’re happy, click the back arrow to select a symbol for the grouped values 

f. Once you’ve selected symbols, in the Primary Symbology pane we can change the label for each 

class. 



Intermediate ArcGIS Pro  18 
 

g. You should now have a map that looks something approximately like the map below. In this 

case, the red stars represent community gardens within 50 metres of a bike path, and the black 

Xs are community gardens farther than 50 metres of a bike path: 

 

Congratulations! You’ve answered a spatial question! 

6. Creating a map layout 
Creating a map layout includes some critical components: north arrow, scale, legend, and title. Legibility 

and understandability of the map are highly important; the map is a communication tool and its layout 

contributes significantly to its usefulness. 

That said, it can be very tedious and quite irritating. There are many buried options, from font sizes to 

text wrapping, so it can be a lot of work to get things looking how you’d like. 

Layouts in ArcGIS Pro: https://pro.arcgis.com/en/pro-app/latest/help/layouts/layouts-in-arcgis-pro.htm  

Make a layout from ArcGIS Pro tutorials: https://pro.arcgis.com/en/pro-app/latest/get-started/add-

maps-to-a-layout.htm  

Create the layout and add your map frame 
a. Save your project! 

b. Right-click on the OttawaNeighbourhoods_totalCyclingNetwork layer and click Zoom To 

c. In the Insert ribbon, click New Layout 

d. Since the shape of Ottawa is wider than it is long, choose ANSI Landscape - Letter 8.5” x 11” 

may be a good fit. 

e. You should now have a blank Layout pane should now appear 

f. On the Insert ribbon, click Map Frame, then the image where you can see the Ottawa 

neighbourhoods 

https://pro.arcgis.com/en/pro-app/latest/help/layouts/layouts-in-arcgis-pro.htm
https://pro.arcgis.com/en/pro-app/latest/get-started/add-maps-to-a-layout.htm
https://pro.arcgis.com/en/pro-app/latest/get-started/add-maps-to-a-layout.htm
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a. If that isn’t an option, click the Map tab beside the Layout tab, do the previous steps, 

then return to the Layout pane. 

b.  
g. Click and drag to draw a rectangle on the blank sheet 

a.  
b. If you need to change the zoom level or where the data appears in the map frame (e.g. 

if the Bronson buffer area is too small in the map frame or you can’t see all the data), 

this is how you can do that: 

i.  Right-click on the map frame and select Activate 

ii. Use the tools in the Navigate section of the Map ribbon to zoom in or drag the 

map 

iii. When it looks the way you want it to, there’s a Layout ribbon 

iv. Select Close Activation 

Add a title, north arrow, and scale bar 
h. In the Insert ribbon, there’s a Map Surrounds section that includes some important map 

components 
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a.  
i. Add the following map surrounds and place them on or near the map frame, somewhere that 

they’re easy to read. Select a style of each and draw it on the layout. 

a. North Arrow 

b. Scale Bar 

i. Once the scale bar is drawn in, click on the scale bar to view the Format Scale 

Bar properties, where you can change the units to kilometers, meters, etc. 

j. To add a title, go to the Insert ribbon then go to the Graphics and Text section and select 

Rectangle Text from the box 

a.  
k. Draw a box where you want your title, probably near the top. Move your map frame if you 

need/want to. 

l. Over on the right, where the Symbology pane is, click the Element tab at the bottom to view the 

Text options 

m. In the Text textbox, give your map an informative title. For ease of reading, the tile can be 

optionally split into multiple lines. 

n. To change the font size, click Text Symbol at the top of the Element pane, then Appearance 

a. Select different sizes/fonts and Apply to make sure the entire title fits! 

o. Save! 

Add a legend and tweak it 
Legends are finicky and can be time-consuming. A couple of things to remember before we start: 

• Every layer that is “on” (visible) in the Map tab and Layout will appear in the legend 

o It can be helpful to go to the map tab (beside the layout tab) and remove all the layers 

you don’t want to see in your final map 

o  
• Even so, the automatically-generated legend will probably be a mess to start 
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p. Adding a legend to the map layout: 

a. Make sure you’re in the Layout tab so you see your piece of paper 

b. Click on the Legend button, select a legend style (you can always delete and add another 

one later), and outline a fairly large area (it’s always changeable) 

q. Configuring the legend: 

a. There’s a lot going on and you can spend a lot of time on the legend, right-click on the 

legend and select Properties 

b. Over in the Drawing Order pane, under Legend, click on OttawaNeighbourhoods so it’s 

outlined in blue 

i.  
c. Over on the Element pane (right side), uncheck Headings 

i. This will get rid of “Summarized Length in METERS” in the legend 

ii.  
d. Now click on CommunityGardens in the Drawing Order pane 

i. Because the <all other values> designation shows up, but actually doesn’t have 

any points in the group, we’ll check off “Only show features visible in the map 

extent” 
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ii.  
r. The numbers that show up in the Ottawa Neighbourhoods dataset are…a bit unwieldy. We can 

change that *but* be aware that method of splitting the values will become Manual (not 

Natural Breaks) and the symbology may change a bit. 

a. In the Drawing Order pane, under the Map Frame section, right-click on the Ottawa 

neighbourhoods layer and select Symbology 

i.  
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b. In the Symbology pane, in the Upper Value column, take a look at the intervals to see if 

there’s a pattern or just pick some equal-interval-ish gaps, like 10s or 15s. 

i. Because I have 5 classes and the intervals are around 7000, I’ll go with that to 

start 

1.  
ii. Double-click in the Upper Value cell and type in a number you want to go with, 

and so on with the rest of the classes. 

iii. Adjust the labels as well, and maybe add a unit to the end (e.g. m for metres) 

1.  
s. To change the names of the layers, right-click on a layer and select Properties 

a. In General, the Name text box is an “alias”, or the name of the layer as it appears in the 

Drawing Order and legend. It doesn’t effect the filename so you can change it to 

something descriptive, such as “Metres of bike paths by Ottawa neighbourhood” 

b.  
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t. The legend isn’t AMAZING but it’s certainly better: 

a. Before:    

b. After:    

u. Save all your hard work!! 

Export your layout 
v. In the Share tab, click Export Layout and select a file type 

a.  
b. In the Layout properties, there will be options like Compression, Resolution, etc. Click 

Export when you’re happy with the settings. 

Fini!       


